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The following guided tour is intended to introduce the user to a
variety of features of SRS 3D, using realistic examples. By the end
of the tour, you should be able to:
•
•
•
•
•

retrieve structures related to your sequence of interest
manipulate the graphical representation of the structure
select the information of interest within the structure
map relevant annotations onto the structure
draw conclusions about the structure of your sequence.

2.1 B-lymphocyte Tyrosine Kinase
Imagine that you are interested in the tyrosine kinase from human
B-lymphocytes, and wish to investigate the likely structure of the
protein.
This section uses the example of human B-lymphocyte tyrosine
kinase to demonstrate how to
• retrieve related structures (see “Finding Related Structures”, p. 9)
• choose which structures to examine in greater detail (see “Choosing an Appropriate Structure to Examine”, p. 13)
• examine the graphical representation of the structure in greater
detail (see “Selection”, p. 16)
• change the appearance of the structure (see “Appearance of the
Structure”, p. 18)
• map the domain boundaries to the structure (see Example 2.5)
• alter the settings of the SRS 3D viewer (see “Customizing the
SRS 3D Viewer”, p. 24).
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Finding Related Structures
1. On the Start page of your local SRS 3D installation (Figure 2.1),
click on either the ‘Start a Temporary Project’ or the ‘Start a Permanent Project’ hyperlink.
Figure 2.1

Figure 2.1 SRS 3D Start page

Note: The type of SRS project that is used determines the mode in
which the SRS 3D viewer opens. See 3.1.1 “Expert or Normal
Mode” (p. 39) for details.
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2. On the Top page, mark the checkbox next to the SWALL database, enter the text human lymphocyte tyrosine kinase in the
‘Quick Search’ text box and click the Quick Search button
(Figure 2.2).
Figure 2.2

Figure 2.2 Quick Search for human lymphocyte tyrosine kinase
Results: A list of SWALL results containing the search terms are
presented in SeqSimple3D view (Figure 2.3).
3. In the results list, click the structure icon relating to the
BLK_HUMAN sequence (marked in Figure 2.3).
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Figure 2.3

Figure 2.3 List of SWALL entries related to human lymphocyte
tyrosine kinase (detail)
Results: All structures in the PDB database with significant
sequence matches to the SWALL entry BLK_HUMAN are
presented in PSSH view (Figure 2.4). Each colored bar represents an
aligned structure, the color indicating the level of sequence identity
(see 5.3.2 “PSSH View”, p. 147)
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Figure 2.4

Figure 2.4 PSSH view of structures with significant matches to
BLK_HUMAN (edited to show fewer hits); A: Text box; B:
Sequence features; D: Aligned structures; E: Tabular summary
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Choosing an Appropriate Structure to Examine
The PSSH view shows that 284 structures show significant
sequence identity with BLK_HUMAN (only some are shown in
Figure 2.4). With so many matches, it is necessary to make a
judgement about which structures to investigate in greater detail.
The PSSH view summarizes the available information on each of
the matching structure, to enable the user to identify those structures
of greatest interest.
In the graphical summary, the black line (Figure 2.4 C) represents
the target sequence, human B-lymphocyte tyrosine kinase. Above
are several colored bars, corresponding to the sequence annotation
(Figure 2.4 B), from SWALL. Moving the mouse over these bars
shows the description of the features in the text box (Figure 2.4 A).
Human tyrosine kinase can be seen to consist of three domains:
SH3, SH2 and protein kinase. The aligned structures below
(Figure 2.4 D) reflect the domain structure. Each domain has some
structures aligned with it, and a small number of structures align
with the entire target sequence.
The aligned structures are ordered and colored by the quality of their
alignment to the target.
• Dark green: at least 99.5% sequence identity
• Light green: high sequence identity (at least 60%, but less than
99.5%)
• Orange: medium sequence identity (at least 30%, but less than
60%)
• Red: low sequence identity (less than 30%).
If any of the structures had shown 100% sequence identity to the
target sequence, they would have been shown in dark green. Moving
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the mouse over the structure bars displays details of the structure in
the text box above.
As none of the aligned structures show 100% sequence identity to
the entire sequence of human tyrosine kinase, it is necessary to
judge which of the retrieved structures would be most useful. If one
particular domain was of principle interest, it would be sensible to
choose the structure that showed the highest similarity to that
domain (e.g. 1blk or 1blj (both with 83% sequence identity to the
relevant part of the target sequence) for domain SH2). In this case,
we are interested in the entire structure, so either 1ad5-A or 1qcf-A
(both with 69% sequence identity to the target sequence) is the most
appropriate starting point.
1. Click on the green bar representing 1qcf-A.
Results: The SwissFeatures3D view (see 5.4.2 “SwissFeatures3D
View”, p. 153) opens, displaying the target sequence,
BLK_HUMAN, aligned onto the structure of 1qcf-A (Figure 2.5).
Using the SRS 3D viewer (see Chapter 3, “SRS 3D Viewer”, p. 35),
the SwissFeatures3D view displays the alignment of the target
sequence with the selected structure. The Structure view
(Figure 2.5 C and see 3.3.1 “Structure View”, p. 42) shows the
structure of 1qcf, colored by similarity to the target sequence,
BLK_HUMAN. The Annotation view (Figure 2.5 D and see 3.3.2
“Annotation View”, p. 46) shows the annotations of the target
sequence, extracted from the SWALL entry. The Sequence overview
(Figure 2.5 E and see 3.3.3 “Sequence Overview”, p. 48) highlights
the secondary structure elements of the sequence and structure,
while the Sequence Description (Figure 2.5 and see 3.3.4 “Sequence
Details View”, p. 49) shows both sequences.
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Figure 2.5

Figure 2.5 SwissFeatures3D view of SWALL entry
BLK_HUMAN aligned onto the structure of PDB entry 1qcf;
A: Blue navigation bar, B: Sequence and structure descriptions,
C: Structure view; D: Annotation view, E: Sequence overview,
F: Sequence details view; G: Description of view
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Selection
Investigate the different types of selection offered by SRS 3D (see
3.4.1 “Selection”, p. 54). Note that the selected regions in one of the
four component views (Figure 2.5 C, D, E and F) are also reflected
in the others.
Example 2.1 Structure selection

1. Click on part of the structure in the Structure view.
Result: That residue or atom is selected and highlighted in the
Structure view, zoomed to in the Annotation view, and highlighted
and zoomed to in the Sequence overview and the Sequence Details
view.
2. Double click on part of the structure in the Structure view.
Result: That residue or atom is selected, highlighted and zoomed to
in the Structure view, the Sequence overview and the Sequence
Details view, and zoomed to in the Annotation view.
3. Double click on the background to remove the selection and
zoom out to the whole structure.
Example 2.2 Secondary structure selection

Either:
1. In the Sequence overview, click on one of the helices (barrelshaped secondary structure elements).
Or:
1. In the Structure view, hold down the Ctrl key and click twice
(slowly, as opposed to a double click) on a single residue in a
helix.
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Result: The helix in which the selected residue is located is selected
and highlighted in the Structure view, zoomed to in the Annotation
view, and highlighted and zoomed to in the Sequence overview and
the Sequence Details view.

Note: Using the Sequence Details view, the sequence of the secondary structure can be noted.

2. Press the Enter key (see 3.4.3 “Zooming”, p. 64).
Result: The selection is zoomed to in the Structure view
(Figure 2.6).
Figure 2.6

Figure 2.6 Highlighted and zoomed-in helix
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3. Press the Tab key (see 3.5.3 “Move Selection Using the Keyboard”, p. 71).
Result: The selection moves to the next secondary structure element
(visible in the Structure view, Sequence overview and Sequence
Details view).
Example 2.3 Range selection

1. In the Sequence Details view, click on one of the residues in the
lower sequence (representing the structure).
2. Holding down the Shift key, click on another residue in the same
sequence.
3. Press the Enter key.
Result: The selected region is selected, highlighted and zoomed to in
the Structure view and Sequence overview, and zoomed to in the
Annotation view.

Note: Selections made in the target sequence (upper sequence) in
the Sequence Details view are not shown in the structure. However,
the selection can be mapped to the structure using the context menu
(Select > Aligned Residues).

Appearance of the Structure
Currently, the structure is shown in ‘Homology’ style, drawing
attention to the sequence similarity of the target sequence and the
structure with which it is aligned. We will now use other
representations to highlight different aspects of the aligned
sequences. See 3.6.1 “Style Sub-Menu” (p. 75), 3.6.2 “Coloring
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Sub-Menu” (p. 79) and 3.6.3 “Representation Sub-Menu” (p. 84)
for details.
Example 2.4 First Impression

1. From the ‘Style’ drop-down menu (top left of the SRS 3D
viewer), select ‘First Impression’.
Result: ‘First Impression’ style is applied, which automatically
selects the most informative representation and coloring options
(see “First Impression”, p. 75). In this example, the different
secondary structures are distinguished by means of assorted
representation and coloring. Attention is drawn to the ligand,
depicted in Spacefill, by the duller coloring of other parts of the
structure. The colors used in the Structure view are also mapped to
the Sequence overview and Sequence Details view.
2. From the ‘Coloring’ drop-down menu, select ‘Secondary Structure’.
Result: All parts of the structure are now brightly colored, as are the
Sequence overview and Sequence Details view (Figure 2.7).
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Figure 2.7

Figure 2.7 HSSPalign entry P51451_1qcf-A in ‘First Impression’
style and ‘Secondary Structure’ coloring
Example 2.5 Coloring by annotation

1. Return the structure to its default state by pressing Ctrl + R.
2. Color the structure using the domain annotation: click in an
empty part of the ‘domain’ annotation lane (see 3.3.2 “Annotation View”, p. 46).
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Figure 2.8

Figure 2.8 HSSPalign entry P51451_1qcf-A colored by domain
Result: The three domains (SH3, SH2 and protein kinase) are shown
in different colors and labeled in the Color legend (Figure 2.8). The
annotation coloring is applied not only to the Structure view, but
also the Sequence overview and Sequence Details view.
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Note: Note all SWALL entries include annotations. If no annotations are available in the SwissFeatures3D view, however, switching
to the IPRmatches view displays domains for most sequences (see
“Access to Other Views:”, p. 157).

3. Click on the protein kinase domain (green) to select and highlight it.
4. Rotate the structure with the mouse to examine the structure of
the three domains (drag the mouse from top to bottom and left to
right). See 3.4.2 “Rotation and Translation”, p. 62 for details.
5. Click again in an empty region of the annotation lane to switch
off domain coloring.
Example 2.6 ATP binding site

1. In the Annotation view, double click on the feature in the
‘np_bind’ annotation lane (see 3.3.2 “Annotation View”, p. 46).
Result: That feature is selected, highlighted and zoomed to in the
Structure view, highlighted in the Annotation view, and highlighted
and zoomed to in the Sequence overview and the Sequence Details
view. However, the selection is difficult to see, as it is partly hidden
behind other regions of the structure.
2. Using the mouse, rotate the structure so that the selection can
more clearly be seen.
3. Zoom in closer (press the + key).
4. Change the representation to make the side chains visible: right
click to open the Context menu (see 3.6 “Context Menu”, p. 74)
and select Representation > Ball & Stick.
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Note: The Ball & Stick representation option is only available in the
Context menu when the full menus are enabled (see 3.6 “Context
Menu”, p. 74)

5. Color the selected residues by element: from the Context menu,
select Coloring > Element.
Result: The details of the binding site are more clearly visible
(Figure 2.9).
Figure 2.9

Figure 2.9 ATP binding site of HSSPalign entry P51451_1qcf-A,
highlighted in Ball & Stick representation with Element coloring
6. Open the Context menu , and select SWISS-PROT from the
‘Links’ sub-menu.
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Result: The HCK_HUMAN entry, linked to the selected structure, is
opened in a new window in SwissEntry view. The view includes
hyperlinks to the relevant references.
7. Double click on the background to remove the selection and
zoom out to the whole structure.

Customizing the SRS 3D Viewer
Example 2.7 Spin

1. Make the structure spin in the Structure view (Context menu >
Options Spin).
2. Alter the speed and direction of spin by dragging the structure
with the mouse. See “Spin” (p. 99) for further details.
3. Turn off the spin again (Context menu > Options Spin).
Example 2.8 Hide Mouse Controls overlay

1. From the Context menu, hide the Mouse Controls overlay
(View > Mouse Controls).
The Mouse Controls overlay is intended to help the novice user
navigate in SRS 3D. It is not visible in expert mode. For further
discussion, see 3.1.1 “Expert or Normal Mode” (p. 39).
Example 2.9 Move as C-alpha Trace

1. Rotate the structure. Note that it is shown in its current representation (e.g. ‘First Impression’) during rotation.
2. Using the Context menu, switch on the ‘Move as C-alpha Trace’
option (Options > Move C-alpha Trace).
3. Rotate the structure again. Note the difference.
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This option is particularly useful if the client computer has a slow
graphics card. See 3.6.3 “Representation Sub-Menu” (p. 84) and
“Move as C-alpha Trace” (p. 98) for details.

2.2 Human Estrogen Receptor
In this section, the example of the human estrogen receptor is used
to:
• make more complex selections
• investigate a ligand-binding site
• investigate mutations.

Finding Related Structures
1. On the Top page, mark the checkbox next to the SWALL database name and click the Standard Query button.
2. From the first drop-down menu, select ‘Description’ and type
estrogen receptor in the text box.
3. From the second drop-down menu, select ‘Organism Name’ and
type human in the text box.
4. Press the Submit Query button.
5. From the list of returned entries in SeqSimple3D view (see 5.1.1
“SeqSimple3D View”, p. 134), click on the icon in the ‘Struct’
that corresponds to the entry ESR1_HUMAN.
Result: The PSSH view for all structures with significant sequence
similarity to SWALL entry ESR1_HUMAN is shown (Figure 2.10).
See 5.3.2 “PSSH View”, p. 147 for details.
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Figure 2.10

Figure 2.10 PSSH view of structures with significant matches to
ESR1_HUMAN (detail)
6. Move the mouse over the sequence features of ESR1_HUMAN
(colored bars above the black sequence bar). Note the descriptions in the text box.
The human estrogen receptor contains a modulating domain at the
N-terminus, a DNA-binding domain (containing two zinc fingers), a
hinge domain and (adjacent) a ligand-binding domain at the
C-terminus. In this example, we will investigate the ligand-binding
domain.
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7. Click on the green bar representing the structure of 1a52-B,
which shows at least 99.5% sequence identity to the ligandbinding domain of ESR1_HUMAN.
Result: The corresponding HSSPalign entry opens in
SwissFeatures3D view (Figure 2.11). See 5.4.2 “SwissFeatures3D
View”, p. 153 for details of the view.
Figure 2.11
x

Figure 2.11 SwissFeatures3D view of HSSPalign entry
P03372_1a52-B
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The PDB structure 1A52 can be seen to consist of two chains. The
SWALL entry, ESR1_HUMAN is only aligned with one chain,
1a52-B, and shows extremely high sequence similarity.
8. Scroll (right mouse drag) through the Sequence Details view to
see if there are any residues that are not identical in the two
sequences.

Complex Selections
In the previous example (2.1 “B-lymphocyte Tyrosine Kinase”,
p. 8), the selections that were made were relatively simple: single
residues, secondary structure elements or residue ranges. Here, more
complex selections will be introduced.
Example 2.10 Simultaneous selection of several regions

1. In the Sequence overview, click on the secondary structure element Helix 9.

Note: The browser status bar shows the description of the feature,
secondary structure element or residue over which the mouse is
held.

2. Zoom out on the Annotation view and Sequence overview to
show the entire alignment: hold down the Shift key and push the
mouse away from you.
3. Add that part of the structure that is aligned with the ‘varsplic’
feature in the SWALL sequence to the selection: hold down the
Ctrl key and click on the feature in the Annotation view.
4. Add the ligand in the aligned chain to the selection: hold down
the Shift key and click on one of the atoms in the ligand.
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Note: Shift + clicking on an atom selects the entire residue. However, some ligands consist of more than one residue. In these cases,
it would be necessary to Ctrl + Alt + click on an atom. See “Shift +
Click: Residue Range Selection” (p. 54) and “Ctrl + Alt + Click:
Add Chain to Selection” (p. 62).

Figure 2.12

Figure 2.12 Complex selection
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5. Add a range of residues to the selection: hold down the Ctrl key
and click on an unselected residue; then hold down the Shift key
and click on an unselected residue elsewhere in the same molecule (Figure 2.12).
6. Copy the selected sequences: press Ctrl + C. Open a word processing program (e.g. Wordpad) and paste the sequences in
(Ctrl + V). See 3.6.8 “Edit Sub-Menu”, p. 95 for further details.
Example 2.11 Hierarchical selection

1. Select a secondary structure element in the Sequence overview
by clicking on it.
2. Add another residue to the selection: in the Structure view, hold
down the Ctrl key and click on an unselected residue
3. Add the entire second secondary structure element to the selection: in the Structure view, hold down the Ctrl key and click
again on the residue selected in the last step.
4. Auto zoom in to the selection by pressing the Enter key.
Example 2.12 Deselection

1. Select the entire structure: press Ctrl + A.
2. Remove Helix 8 from the selection: hold down the Ctrl and Shift
keys, and click on Helix 8 in the Sequence overview.

Note: The browser status bar shows the description of the feature,
secondary structure element or residue over which the mouse is
held.

3. Remove one of the ligands from the selection: hold down the
Ctrl and Shift keys, and click on one of the atoms in the ligand.
Once that atom has been deselected, hold down the Ctrl and
Shift keys, and click on it again.
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4. Auto zoom out to the whole structure by pressing Shift + Enter.

Ligand-binding site
Example 2.13 View the ligand-binding site

1. From the Context menu (right click to open), select ‘Ligands’
from the ‘Select’ sub-menu (see 3.6.9 “Select Sub-Menu”,
p. 96) (or press Ctrl + L).
2. From the Context menu (right click to open), select
‘Proximity 4 Å’ from the ‘Select’ sub-menu (see 3.6.9 “Select
Sub-Menu”, p. 96).
3. Press the Enter key.
Result: All residues within 4 Å of the ligand are highlighted, shown
in Ball & Stick representation and zoomed in on. These residues are
likely to constitute the ligand-binding site.
4. Use the mouse to rotate the structure around the X- (drag up and
down), Y (drag right to left) and Z axes (hold down the Ctrl key
and drag left to right) to view the binding site residues.
Result: Many of the binding-site residues are obscured by other
parts of the structure. Instead, we will use a specially designed style.
Example 2.14 ‘Binding Site’ style

1. From the ‘Style’ drop-down menu, select ‘Binding Site’. See
3.6.1 “Style Sub-Menu”, p. 75 for more details.
2. Zoom in on one of the binding sites: hold down the Shift key and
pull the mouse toward yourself.
3. Centralize the binding site: use the right mouse drag to translate
the structure (Figure 2.13).
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Figure 2.13

Figure 2.13 Ligand-binding site in ‘Binding Site’ style
4. Select the ligand: Alt + click on one of the ligand residues.
5. Select the surrounding residues: from the Context menu, select
‘Proximity 4 Å’ from the ‘Select’ sub-menu.
6. View the distribution of the residues involved in the binding site:
press the up arrow.
7. Label the residues: from the Context menu, select
Label > Residue.
8. Auto zoom out to the selection: press Enter.
Result: The binding residues are selected, highlighted and labeled in
the Structure view, and highlighted in the Sequence overview and
Sequence Details view (Figure 2.14).
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Figure 2.14

Figure 2.14 Binding site residues (edited to hide Annotation view)
9. Turn off the labels: from the Context menu, select
Label > Residue.
Example 2.15 Mutations

1. Click in an empty region of the ‘variants’ annotation lane (see
3.3.2 “Annotation View”, p. 46).
Result: The Structure view, Sequence overview and Sequence
Details view are colored according to the ‘variants’ annotation:
known mutations in red, and the rest in gray.
2. Click on one of the red residues.
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Result: The details of the selected residue are shown in the Selection
overlay (Figure 2.15). If the selection overlay is not visible, choose
View > Selection from the Context menu.
Figure 2.15

Figure 2.15 Coloring by ‘variant’ annotation
3. Click again in an empty region of the ‘variants’ annotation lane
to turn off the annotation coloring.

